Missing parms in kdc.conf (FINALLY WORKING)

Mark Sellers contact at reef-rats.com
Sat Nov 27 16:24:31 EST 2004

So chalk this one up to a "Debian-ism".  The problem was that the
Debian install assumes everything that would normally be in
/var/lib/krb5kdc on other platforms is in /etc/krb5kdc.  My config
files were placing the databases in /var, but when I just let it put
the files where it wanted (i.e. /etc/krb5kdc), then it worked fine.

The interesting aspect is that strace (and other mechanisms) all
reported that the krb5.conf and kdc.conf files were being found and

So thanks for the input.  For all of Debian's stengths, this wasn't
one of them ;-(  I'm still not exactly sure why it wouldn't work with
the databases redirected to /var, but I don't have enough "free time"
to UTSL any more than I already have.


On Fri, 26 Nov 2004 17:36:11 +0000 (UTC), kenh at cmf.nrl.navy.mil (Ken
Hornstein) wrote:

> >kdb5_util: Required parameters in kdc.conf missing while initializing
> >the Kerberos admin interface
> Unfortunately, many times with these errors, it's UTSL.
> There is only one place where this error is returned.  It's in
> lib/kadm5/srv/server_init.c.  Reading this, here is the list of
> required parameters:
>                          KADM5_CONFIG_ADBNAME | \
>                          KADM5_CONFIG_ADB_LOCKFILE | \
>                          KADM5_CONFIG_ENCTYPE | \
>                          KADM5_CONFIG_FLAGS | \
>                          KADM5_CONFIG_MAX_LIFE | KADM5_CONFIG_MAX_RLIFE | \
> Some of thoses have built in defaults.
> But I think I see your problem.  You want the kdc.conf in /var/lib/krb5kdc.
> (What is /etc/krb5kdc?).  You should be able to use a system call tracer
> to see what file it's trying to open.
> --Ken
> ________________________________________________
> Kerberos mailing list           Kerberos at mit.edu
> https://mailman.mit.edu/mailman/listinfo/kerberos

More information about the Kerberos mailing list