DNS server hangs in/after gss_indicate_mechs call on Windows with krb5-1.9 libs

Tom Yu tlyu at MIT.EDU
Fri Feb 25 15:26:47 EST 2011

"Elzey, Blaine A (Blaine)" <blaine.elzey at alcatel-lucent.com> writes:

> I am running DNS on Windows 2008, my KDC is Windows 2003 SP2.  On the DNS server machine I see the krb5.ini is read, but the specified default_keytab_name file is never opened.  I have tried many variations for the syntax of the default_keytab_name value to no avail.  I have also tried variation of different libdefaults values with no luck. The DNS server does not answer any queries about 2 seconds after starting. The last action the process monitor sees is the successful IRP_MJ_CLEANUP operation for the krb5.ini file (after successful open and read.)  I do see context swithes climb slowly for the process, but nothing else (no CPU or IO). The stack:

Which DNS implementation are you trying to run?

> Krb5.ini:
> [libdefaults]
>         default_realm = LABW2K3.COM
>         default_keytab_name = C:/Files/dev/krb5.keytab

This should probably be

          default_keytab_name = FILE:C:\Files\dev\krb5.keytab

but I would have to check for details.

More information about the krbdev mailing list