Namespace update

ghudson@MIT.EDU ghudson at MIT.EDU
Tue Aug 24 12:31:42 EDT 2010

Historically, we've used krb5int_ as our prefix for linker-visible
internal symbols.  In the name of conciseness, we've decided to start
using k5_ for that purpose in the future.  You may have seen some
examples of that cropping up, such as in the plugin architecture
project page.

Since this is really a bikeshed issue with no impact on consumers of
krb5, I didn't see the need to have a debate within the full dev
community.  I've gone ahead and updated

We're not currently planning on going through and renaming all of the
existing krb5int_ symbols.

More information about the krbdev mailing list