Miscellaneous coding practice changes
tsitkova at MIT.EDU
Thu Dec 3 11:34:53 EST 2009
On Dec 1, 2009, at 4:30 PM, ghudson at MIT.EDU wrote:
> Here are some minor coding practice changes we've discussed at team
> 1. Amend the namespace section to recommend against using the krb5_ or
> krb5int_ prefixes for static functions. This allows static functions
> to have shorter names and avoids some kinds of confusion (particularly
> when a krb5_ prefix makes the function look like an API function).
Can we add kadm5_ to the list of undesirable static function name
prefixes as in
static void kadm5_free_principal(...) ?
More information about the krbdev