broken compatability between 1.3.5 and 1.4.1

Tim Mooney mooney at
Thu Sep 29 18:42:02 EDT 2005

In regard to: broken compatability between 1.3.5 and 1.4.1, Paul Moore said...:

> Did you know this? The shared libraries are not binary compatible.
> Certainly GSS applications built against the 1.3.5 libraries do not work
> against 1.4.1 libs.
> There is a missing symbol that the loader picks up in some cases.
> a good example is openssh 3.9 built against 1.3.5. It segfaults against
> 1.4.1 when a gss connection comes into sshd

I reported this earlier too (February 10th), and it's bug # 2920 in
the MIT Kerberos bug database.

I'm glad you reported it; until now, it was looking like I was the only
person that had seen this.

Tim Mooney                              mooney at
Information Technology Services         (701) 231-1076 (Voice)
Room 242-J6, IACC Building              (701) 231-8541 (Fax)
North Dakota State University, Fargo, ND 58105-5164

More information about the krbdev mailing list