Kerberos for OS X 10.2 responds poorly to infinite recursion in /Library/Preferences/

Nicholas Riley njriley at
Wed Jan 15 17:08:02 EST 2003


I just attempted to use Kerberos:

[p5:5005] ~%kinit njriley at UIUC.EDU
Kerberos Login:
Please enter the password for njriley at UIUC.EDU: 
Kerberos Login Failed: Invalid Kerberos 5 context

When I tried to use the Kerberos login app, KerberosLoginServer crashed:

Thread 0 Crashed:
 #0   0x943a9564 in krb5_get_profile
 #1   0x943c161c in  UKLEnvironment::RealmShouldHaveKerberos5(std::basic_string<char, std::char_traits<char>, std::allocator<char> > const&)
 #2   0x943cc93c in __KLInternalRealmShouldHaveKerberos5

I tracked it down to (oops):

[p4:5008] /Library/Preferences%more
more: Too many levels of symbolic links
[p4:5009] /Library/Preferences%ls -l
lrwxrwxr-x    1 root     admin          54 Jan 11 19:45 -> /Volumes/Mac OS X/Library/Preferences/

Everything worked fine after restoring from backup.
It would be nice if KfM provided a slightly nicer error message in
this case. :)

=Nicholas Riley <njriley at> | <>
        Pablo Research Group, Department of Computer Science and
  Medical Scholars Program, University of Illinois at Urbana-Champaign

More information about the krbdev mailing list