Fink/MIT Kerberos interference?

Alexandra Ellwood lxs at MIT.EDU
Tue May 21 10:15:14 EDT 2002

>After my latest self-update to fink and updating of packages 
>(5/17/02), I found that CLI Kerberos commands (klist, kinit, etc) no 
>longer worked; no reply from them at all, though I could ^C out.

Which packages did you update other than Fink?  What version of Mac 
OS X are you running?

I'm not sure why the tools are hanging, but I'm not familiar with 
Fink or what it contains.  Could you run any of the CLI binaries in 
gdb and send us a backtrace after the binary hangs?

>When running a hacked version of OpenSSH that worked before (after 
>creating a ticket with the Kerberos application), I got:
>[hahn:/usr/lib] hahn% ~/ssh b0dap30
>dyld: /Users/hahn/ssh multiple definitions of symbol _des_set_key
>/Users/hahn/ssh definition of _des_set_key
>/usr/lib/libcrypto.0.9.dylib(set_key.o) definition of _des_set_key

This is happening because OpenSSL and Kerberos both define DES 
symbols.  Supposedly a future version of OpenSSL will have different 
names for the DES symbols so they don't conflict with other DES 

>Now I'll try reinstalling MIT Kerberos 4.0.

Let us know if this helps.

Alexandra Ellwood                                               <lxs at>
MIT Information Systems                     

More information about the krbdev mailing list