Fetch 4.0.2 fails on OS X 10.2 - "Hostname cannot be canonicalized"

Ken Hornstein kenh at cmf.nrl.navy.mil
Wed Aug 28 12:56:01 EDT 2002

I'm having a strange problem, and I can't figure out what's going on.

I'm trying to use Fetch 4.0.2 on OS X 10.2 (with GSS-API support, naturally).
However, when I try to connect to one of our hosts here, I get
the following error:

GSSAPI error: An invalid name was supplied
Hostname cannot be canonicalized

Which makes _no_ sense to me, since I supplied Fetch a FQDN.  This is all
vanilla stuff on OS X, with the MIT installed Kerberos extras.

Some more weridness: Other supplied OS X Kerberos apps work fine in our
realm.  Even other _GSSAPI_ apps (like the built-in Mail app) work fine
... to the same host that I tried for Fetch, even.  Even weirder, I
tried a principal from another realm that we share a cross-realm key
with, and _it_ works fine ... only to hosts in that other realm.  If I
try to connect to hosts in this realm, it does _not_ work (even though
it should via cross-realm).  However, I cannot use my realm ticket to
access hosts in the other realm; I get the same error.

I'm stumped on this one; anyone else got any ideas?


More information about the krbdev mailing list