kpasswd not listening

Darek hello at
Thu Dec 25 16:31:14 EST 2008

I am running version 1.6.3 on FreeBSD 7.0-RELEASE, installed from ports.

I start the daemon with /usr/local/sbin/krb5kdc

This starts

root     krb5kdc    38718 99 udp4         *:*
root     krb5kdc    38718 100udp4          *:*

(only showing localhost, but public IPs listening as well)

However, I do not see a passwd daemon running.  Tried specifying it in 
/etc/kdc.conf with "kpasswd_port = 464" in my realm and still no go.

Surprisingly, I've not found much info online.  Maybe I'm searching for 
the wrong thing.  Despite this, I tried running kpasswd from the kdc 
itself and got:

kpasswd: krb5_change_password: unable to reach any changepw server  in 

Any pointers?  Ticket granting and ssh/sudo both work, but I'd want to 
give users the ability to change their pass and not hassle me. :P

- Darek

My /etc/krb5.conf:
        default_realm = DOMAIN.NET
        DOMAIN.NET = {
                kdc =
                admin_server =
[domain_realm] = DOMAIN.NET
        min_length = 8
        min_classes = 3

More information about the Kerberos mailing list