SSH Problem with Kerberos

Barry Allard barry.allard at
Thu Mar 16 13:24:24 EST 2006

Hi Konstantin,

Try this

Kind Regards,
Barry Allard

Konstantin Boyanov wrote:

>Hi there,
>I'm really new to all this Kerberos thing, so in the next sentences you may
>find some true luser talk. Pleas forgive me :)
>I'm trying to configure an MVME6100 machine running RHLE 4 to work in an AFS
>environment with Kerberos authentication. Especially SSH access to the
>machine with an existing AFS account. So... I installed MIT Kerberos 1.4 on
>the new machine and tried to connect to it with SSH. But it only works with
>local accounts, not with my AFS account. When trying to kinit on the new
>machine, the program is complaining about some missing file:
>klist: No ticket file: /tmp/krb5cc_0
>On the other hand I don't think I've done the whole configuration files
>stuff right - especially the ones krb5.keytab and krb-srvtab. I've tried to
>copy (steal actually :) ) these files from other working machines on the
>company's network, but after all krb5.keytab and krb-srvtab are only
>root-readable, and I don;t have sufficient access rigths to do it.
>So my question is - how it is the authentication / configuration of a new
>machine on the network done, using Kerberos and enabling SSH access to it
>with the AFS tokens already obtained. I have googled the net for a week or
>so but haven't found any good explanation and documentation obout it. Only
>some sample files that worth nothing to me...
>Once again sorry for the lame questions but I really need this done and I'm
>already desperate enogh to think that I woun't make it at the end.
>Any help is wellcome. Thank you.
>Best Regards,
>Konstantin Boyanov
>Kerberos mailing list           Kerberos at

More information about the Kerberos mailing list