Missing parms in kdc.conf

Mark Sellers contact at reef-rats.com
Mon Nov 22 22:39:19 EST 2004

It's finding my kdc.conf without this entry.  I know this because
I can add garbage to my kdc.conf and it will fail to parse it.
However, just to be sure, I added the [kdc] section with a
profile key, and I receive the same error.

I read in some news post that the error could also apply to
missing parameters in the krb5.conf file (i.e. the error text is
wrong).  Still, I don't see what is missing.  I'm bewildered on
this one.  It's gotta be something simple.

For reference, I'm running a 2.6.6 kernel (Debian) with Kerberos
5 version 1.3.4-4.

Thanks for the input.  Do you have any other suggestions?


On Mon, 22 Nov 2004 22:11:08 -0500, bob <bob at cox.net> wrote:

> Mark Sellers wrote:
> > I am getting the following Kerberos 5 error:
> > 
> > kadmind: Required parameters in kdc.conf missing while
> > initializing, aborting
> > 
> > I have tried all the obvious things like reading man pages, admin
> > guides, and searching the web for examples.  I have also tried
> > plenty of trial and error, but to no avail.  Can someone please
> > point me in the right direction for solving this [presumably]
> > simple problem.
> > 
> > Conf files follow.  I have replaced my domain name with FOO.
> > 
> > Regards,
> > Mark
> > 
> Is your kdc.conf file in the default location?  If not you can add the 
> following to your krb5.conf:
> [kdc]
> 	profile = /path/to/kdc.conf

More information about the Kerberos mailing list