GSS-API error acquiring credentials

Wyllys Ingersoll wyllys.ingersoll at
Mon Jun 16 09:27:26 EDT 2003

Muhammed Reahan wrote:
> Topic     GSS-API error acquiring credentials
> Hi
> I want to develop a Demo application using GSS-API which uses the authentication mechanism of  
> Kerberos I had write the gss-server programe. It is successfully compiled there is no logical 
> error. But every time I tried to run the program it gives following error message
> 1. GSS-API error acquiring credentials: No credentials were supplied, or the credentials were 
> unavailable or inaccessible
> Or Invalid name is supplied 
> 2. GSS-API error acquiring credentials: mech_dh: Success
> I have configured the SEAM in Solaris operating system kdc is running fine It grants ticket and 
> authenticate the user registered But one thing I can not understand that same error message is 
> answered by the application on  both system which have master kdc installed and on the system 
> which have not configured kdc or slave kdc
> I don’t know what to do next I am trying to solve this problem from one month .
> But I have not succeeded yet . I request u Sir please please   help me……….. ?
> I would be thankful to u.
> By Reahan From Bahria  university Islamabad (MCS)

Make sure the list of valid GSSAPI mechanisms in /etc/gss/mech has
the 'kerberos_v5' entry as the first valid entry in the list.

More information about the Kerberos mailing list