GSS-API error acquiring credentials

Muhammed Reahan reahan2001 at
Fri Jun 6 11:17:05 EDT 2003

Topic     GSS-API error acquiring credentials
I want to develop a Demo application using GSS-API which uses the authentication mechanism of  
Kerberos I had write the gss-server programe. It is successfully compiled there is no logical 
error. But every time I tried to run the program it gives following error message
1. GSS-API error acquiring credentials: No credentials were supplied, or the credentials were 
unavailable or inaccessible
Or Invalid name is supplied 
2. GSS-API error acquiring credentials: mech_dh: Success
I have configured the SEAM in Solaris operating system kdc is running fine It grants ticket and 
authenticate the user registered But one thing I can not understand that same error message is 
answered by the application on  both system which have master kdc installed and on the system 
which have not configured kdc or slave kdc
I don’t know what to do next I am trying to solve this problem from one month .
But I have not succeeded yet . I request u Sir please please   help me……….. ?
I would be thankful to u.
By Reahan From Bahria  university Islamabad (MCS)

Do you Yahoo!?
Free online calendar with sync to Outlook(TM)..From uli.schroeder at Fri Jun  6 14:27:41 2003
	by (8.12.8p1/8.12.8) with ESMTP id h56IRfk0012605
	for <kerberos at>; Fri, 6 Jun 2003 14:27:41 -0400 (EDT)
Received: from ( [])
	for <kerberos at>; Fri, 6 Jun 2003 14:27:40 -0400 (EDT)
Received: (qmail 5523 invoked by uid 65534); 6 Jun 2003 18:27:38 -0000
Received: from (EHLO merkur) (
  by (mp021) with SMTP; 06 Jun 2003 20:27:38 +0200
From: =?iso-8859-1?Q?Uli_Schr=F6der?= <uli.schroeder at>
To: <kerberos at>
Date: Fri, 6 Jun 2003 20:28:18 +0200
Message-ID: <000301c32c59$6a47aea0$01c7a8c0 at merkur>
MIME-Version: 1.0
Content-Type: text/plain;
Content-Transfer-Encoding: 7bit
X-Priority: 3 (Normal)
X-MSMail-Priority: Normal
X-Mailer: Microsoft Outlook, Build 10.0.4024
Importance: Normal
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1106
Subject: krb5 "Error Code 52" - UDP packet size - TCP fallback
X-BeenThere: kerberos at
X-Mailman-Version: 2.1
Precedence: list
List-Id: The Kerberos Authentication System Mailing List <>
List-Help: <mailto:kerberos-request at>
List-Post: <mailto:kerberos at>
List-Subscribe: <>,
	<mailto:kerberos-request at>
List-Archive: <>
List-Unsubscribe: <>,
	<mailto:kerberos-request at>
X-List-Received-Date: Fri, 06 Jun 2003 18:27:41 -0000

Hi folks,

I have a problem authenticating my RedHat 9 against Active Directory. 
I'm running the MIT implementation of kerberos.

When I run kinit for my testuser it works fine. The testuser ist just a 
member of the domain with read access to the directory. No other groups 
or permissions. When I try to do a kinit for my own account with all its

group memberships, etc., I just get the error code 52. I read on the 
internet that this is because the Windows 2000 server switches from UDP 
to TCP if the maximum packet size is exceeded. I think this happens with

all my "normal" users.

It seems like a lot of people managed to authenticate against AD. 
Maybesomeone can help me with this problem and tell me how he solved it.

Thanks in advance.


More information about the Kerberos mailing list