kdb5_util with -mkey_convert

Mike Friedman mikef at ack.Berkeley.EDU
Mon Jun 24 12:27:06 EDT 2002

On Mon Jun 24 08:50:31 2002, Nicolas.Williams at ubsw.com said:

> Well, I've used this feature all of one time... And then I used the other
> undocumented option (-new_mkey? I forget - look in the source and try it)
> to tell kdb5_util where the new stash file was.
> But, given the recent posts on the MIT lists re: the byte order dependence
> of the stash files I would venture a guess that that is your problem. I.e.,
> I suspect that you're trying the key change on a machine whose arch is very
> different from the machine on which the stash file you're using was created.

I just tried it using a new stash file (specifying '-new_mkey_file'), and got
the same results.  This stash file I created on my new 1.2.5 machine.  Besides,
the old stash file, which works fine with ordinary dumping (no key change), was
created on a Solaris 7 system;  my 1.2.5 system is Solaris 8.  So I wouldn't
expect a severe architectural discrepancy.

> Beyond this I cannot help you... You would do well to compile the kdb5_util
> with -g and post a backtrace though, should you still get a core dump.

At some point I may do that.  But since this isn't critical for me now and I'm
short on time in going production with 1.2.5, I'll probably forgo use of the
new feature for the present.



Mike Friedman                             System and Network Security
mikef at ack.Berkeley.EDU                    2484 Shattuck Avenue
1-510-642-1410                            University of California at Berkeley
http://ack.Berkeley.EDU/~mikef            http://security.berkeley.edu

More information about the Kerberos mailing list