kdb5_util with -mkey_convert

Nicolas.Williams@ubsw.com Nicolas.Williams at ubsw.com
Mon Jun 24 11:50:31 EDT 2002

Well, I've used this feature all of one time... And then I
used the other undocumented option (-new_mkey? I forget - look
in the source and try it) to tell kdb5_util where the new
stash file was.

But, given the recent posts on the MIT lists re: the byte order
dependence of the stash files I would venture a guess that that
is your problem. I.e., I suspect that you're trying the key
change on a machine whose arch is very different from the
machine on which the stash file you're using was created.

Beyond this I cannot help you... You would do well to compile
the kdb5_util with -g and post a backtrace though, should you
still get a core dump.



> -----Original Message-----
> From: Mike Friedman [mailto:mikef at ack.Berkeley.EDU]
> Sent: Sunday, June 23, 2002 5:47 PM
> To: Williams, Nicolas
> Cc: turbo at bayour.com; kerberos at mit.edu
> Subject: kdb5_util with -mkey_convert
> On Tue May 21 10:28:03 2002, Nicolas.Williams at ubsw.com said:
> > Are you using different KDB master keys on the two hosts? 
> That would explain
> > the decrypt integrity check failure message from the KDC. 
> If so then you
> > must change the master key during dumping. There's a couple 
> of undocumented
> > options for this, -mkey_convert and -new_mkey_file <stash filename>.
> Nico,
> I'm about to upgrade my KDC, to new machines and from 1.2.1 
> to 1.2.5, so I
> figured I'd try the above-mentioned undocumented option, to 
> change my master
> db key.  After double-checking the syntax in the source code, 
> I ran the
> following:
>    kdb5_util dump -mkey_convert
> After entering the new db password twice, I got a SEGV fault!
> The database I tried this on was a copy of my production db.  
> I had copied
> the latest slave_datatrans from my 1.2.1 KDC to the 1.2.5 KDC and then
> reloaded it.  In fact, I also dumped and reloaded it again on 
> 1.2.5 (just
> to make sure the new policy dumping works).  Then I tried the 
> dump with
> '-mkey_convert' and got the SEGV.
> (My KDC is running on Solaris 8).
> Has anyone tried the '-mkey_convert' option and gotten it to 
> work?  I have
> no problem with dumps and reloads as long as I don't try to 
> change the db key.
> Thanks.
> Mike
> --------------------------------------------------------------
> ----------------
> Mike Friedman                             System and Network Security
> mikef at ack.Berkeley.EDU                    2484 Shattuck Avenue
> 1-510-642-1410                            University of 
> California at Berkeley
> http://ack.Berkeley.EDU/~mikef            http://security.berkeley.edu
> --------------------------------------------------------------
> ----------------

Visit our website at http://www.ubswarburg.com

This message contains confidential information and is intended only 
for the individual named.  If you are not the named addressee you 
should not disseminate, distribute or copy this e-mail.  Please 
notify the sender immediately by e-mail if you have received this 
e-mail by mistake and delete this e-mail from your system.

E-mail transmission cannot be guaranteed to be secure or error-free 
as information could be intercepted, corrupted, lost, destroyed, 
arrive late or incomplete, or contain viruses.  The sender therefore 
does not accept liability for any errors or omissions in the contents 
of this message which arise as a result of e-mail transmission.  If 
verification is required please request a hard-copy version.  This 
message is provided for informational purposes and should not be 
construed as a solicitation or offer to buy or sell any securities or 
related financial instruments.

More information about the Kerberos mailing list