Subject: [Wocky] Fwd: [Macpartners] Jabber settings for iChat

From: Theresa M Regan <[email-masked]>
Date: Wed, 1 Feb 2006 11:11:51 -0500

Good Morning,

by chance, is any one familiar with this configuration and able to  
assist Helen (Rose)?

Cheers,
Theresa

p.s.  if a response is posted, please include <[email-masked]>

Begin forwarded message:

> From: Helen Rose <[email-masked]>
> Date: February 1, 2006 10:55:24 AM EST
> To: [email-masked]
> Subject: [Macpartners] Jabber settings for iChat
>
> I'm trying to get going with Jabber on iChat (v3.1.1 on OS 10.4.4).
> These are the settings I'm using:
>
> Jabber ID: [email-masked]
> Password: (Kerberos pw)
> Server: jabber.mit.edu
> Port: 5222
> Connect using SSL - CHECKED
> Allow self-signed certificates - CHECKED
> Warn before password is sent insecurely - CHECKED
>
> When I try and connect, iChat returns an error: "Could not connect to
> Jabber. An unexpected SSL error occured. [-9806]"
>
> Can someone point me to my mistake?
>
> Thanks!
>
> --Helen
>
> _______________________________________________
> Macpartners mailing list
> [email-masked]
> http://mailman.mit.edu/mailman/listinfo/macpartners

---

From: Helen Rose <[email-masked]>
Date: Wed, 1 Feb 2006 11:26:46 -0500

On Feb 01, 2006, at 11:23, Jonathan Reed wrote:

> You need to set the port to 5223 which is, I believe the "old- 
> style" SSL port.  Port 5222 only works for TLS, I think.
>
> Regardless, setting it to port 5223 will work.
>

That worked; thanks!

I used port 5222 after finding a Stock Answer that listed that port:
http://itinfo.mit.edu/answer.php?id=7922

Someone may want to update it.

--Helen

---

From: Jonathan Reed <[email-masked]>
Date: Wed, 1 Feb 2006 11:28:51 -0500

That stock answer is correct, since it's for Adium, not iChat.  Adium 
does support TLS - iChat only uses the "old-style" SSL.

-Jon

At 11:26 AM -0500 2/1/06, Helen Rose wrote:
>>You need to set the port to 5223 which is, I believe the 
>>"old-style" SSL port.  Port 5222 only works for TLS, I think.
>>

-- 
-------------------
Jonathan Reed

[email-masked]
-------------------

---

From: Jonathan Reed <[email-masked]>
Date: Thu, 2 Feb 2006 12:35:42 -0500

I took some screenshots a while ago, I thought I had sent them to the 
list, but I can't find them in my Outbox.

Here is a brief (as in, the grammar and possibly spelling needs 
cleanup) writeup with screenshots.

http://web.mit.edu/jdreed/Public/ichat/ichat.html

Someone may actually want to follow these instructions step-by-step 
to make sure they're correct.

-Jon

At 11:18 AM -0500 2/2/06, Heather Anne Harrison wrote:
>A better answer might be to create a stock answer for ichat.  Do
>we have the settings info for ichat?  I'd be glad to draft one
>if somebody has the technical info handy.
>
>Heather Anne
>[email-masked]
>

-- 
-------------------
Jonathan Reed

[email-masked]
-------------------

---

From: Heather Anne Harrison <[email-masked]>
Date: Thu, 2 Feb 2006 13:44:00 -0500

Thanks.  I'll turn that into a stock answer with the appropriate
warnings that we don't really support ichat.

Heather Anne
[email-masked]

---

From: Heather Anne Harrison <[email-masked]>
Date: Wed, 8 Feb 2006 11:11:14 -0500

Here's a draft stock answer.  I did not include the screen shots
at this point, but may add some later once I get them hosted
somewhere appropriate.

Sorry to be so slow getting this done.  I had some significant
issues getting this to work on my system.  A reinstall of iChat
fixed it, so I'm going to assume it was a corrupted file of some
sort.

http://itinfo.mit.edu/answer.php?id=8061

Let me know if you have any feedback/suggestions.

Thanks!

Heather Anne
[email-masked]