Subject: [Mitbadminton] mitbadminton-tomorrow(Sunday) 9-10 am north court

From: Yuan Mei <[email-masked]>
Date: Sat, 08 Dec 2007 18:34:07 -0500

Hi, All
    I have reserved Zesiger Center north court 9-10 am tomorrow. Sorry I 
can not book any better slot because they have a basketball
game tomorrow. All afternoon and evening slots are taken up.

Best
-Yuan

---

From: Yuan Mei <[email-masked]>
Date: Sat, 15 Dec 2007 16:20:10 -0500

Hi, All
    Due to the reason that they have a volleyball game, we can just reserve north court 10-11 pm Zesiger Center tomorrow. 
    So it is Sunday, 10-11 pm, north court.
    Have fun.

Best
-Yuan