Subject: [Mitbadminton] Schedule this Sat.

From: "Yuan Xiao" <[email-masked]>
Date: Sat, 22 May 2004 00:36:03 -0400

Guys,

Sorry for my late informing.  This time we get two hours on Sat, from 10am to 12 am,
south courts. Hope you can get my email in time.

Best,
Xiao, Yuan

---

From: "Xiaosong Jacky Chen" <[email-masked]>
Date: Sat, 22 May 2004 00:36:22 -0400

Please excuse me for the spam if you are not interested. Please call
225-7222 or [email-masked], Baker room 222.
 
NEW Sealed ONE PAIR Badminton Racket, FREE 12 Badmintons, bought $99,
you pay $59