X-CACHECONF in cache type 0504
Tim at cybersafe.com
Fri Nov 19 10:54:29 EST 2010
Thanks. I guess, what I need to know is, do we need to store our own
configuration data with krb5_ccache_conf_data as the name and X-CACHECONF
as the realm ? It seems that the name krb5_ccache_conf_data is referring
to a function name in the MIT/Heimdal code ? We do not have a function
with this name in our code, and do not plan to add such a function, so if
we use different name in cache to store configuration data, will this
break interoperability ?
On 19/11/2010 15:49, "Sam Hartman" <hartmans at MIT.EDU> wrote:
>>>>>> "Tim" == Tim Alsop <Tim at cybersafe.com> writes:
> Tim> On 19/11/2010 05:52, "Greg Hudson" <ghudson at MIT.EDU> wrote:
> >> For the purposes of ignoring config entries in our klist, we
> >> recognize config entries if they match both the realm
> >> (X-CACHECONF:) and the first component of the name
> >> (krb5_ccache_conf_data).
> Tim> Is above only true for MIT implementation ? E.g. If/when
> Tim> Heimdal or ourselves (CyberSafe) want to store config data in
> Tim> cache, can we use different component name and realm name ?
> Tim> Also, is this config data described in a draft or RFC, or is it
> Tim> 100% proprietary to MIT code ?
>Well, the patch was submitted to us by one of the Heimdal developers, so
>it is quite possible they will do something (or have done something)
>krbdev mailing list krbdev at mit.edu
More information about the krbdev