lukeh at padl.com
Mon Aug 24 17:14:00 EDT 2009
> * Do not make lines overflowing 79 columns if possible. Examples:
Yeah, that's a bad habit of mine. I need to get a VT100.
> * Do not put parens around return expressions:
> - g_acquire_cred_imp_cred.c
> - g_acquire_cred_imp_name.c
> (These may be the result of copying existing code.)
Right, I agree in principle, but I wanted to make it compatible with
the existing Sun convention.
> - kdc_process_s4u2self_rep is a bad name. "kdc_process_*" was
> previously used only for examining request data, and is a bad name
> prefix even then. In this case you are composing reply data. Also,
Right, I attempted to keep it consistent with _req but, that makes
sense. Do you want to fix these things or shall I?
> * Do not check for nullity before calling free or krb5_free functions.
> (I don't think this is in the coding practices document but is what
> we're moving towards.) Examples:
Right, I was curious about that; my habit is not to check for nullity,
but I generally followed the existing practice which does.
> * Unrelated #if 0s added to ksetpwd.c.
From memory, that's a security issue, printing the password to the
standard output... but yes, unrelated.
Thanks for the comments. I may not have hours to address these until
More information about the krbdev