Compilation problem on HPUX

nukala krishna hari_nv2001 at
Thu Aug 30 07:59:03 EDT 2007


When i use ./configure CC='gcc -muinx=95' it crossed the previous problem. Since we feel that it is not a good idea and I use aCC complier to compile my code, I thought of using aCC instead of gcc.
I tried to compile the code using the below command

./configure CC="aCC"

But I ran into problems. Does 1.4 Release supports compilation using aCC? What are the compilers it supports other than gcc?


----- Original Message ----
From: Ken Raeburn <raeburn at MIT.EDU>
To: nukala krishna <hari_nv2001 at>
Cc: Kerberos dev team <krbdev at>
Sent: Thursday, 30 August, 2007 6:15:00 AM
Subject: Re: Compilation problem on HPUX

On Aug 29, 2007, at 12:52, nukala krishna wrote:
> Target: hppa2.0w-hp-hpux11.11

> configure:1700: checking for C compiler default output
> configure:1703: gcc    conftest.c  >&5
> /usr/ccs/bin/ld: Can't open unix98.o
> /usr/ccs/bin/ld: No such file or directory
> collect2: ld returned 1 exit status
> configure:1706: $? = 1

> Here the log says that, it is looking for unix98.o. But my machine  
> is having unix95.o in /usr/lib directory. I don't have unix98.o in  
> my machine. Can't I build using unix95.o? If I can, does it results  
> to any side effects?
I'm not really familiar with the ins and outs of the HP-UX build  
environment.  After poking around at the gcc docs 
onlinedocs/gcc-4.1.2/gcc.pdf and the HP-UX compiler docs at http://, it looks to me like  
unix98.o is a system object file used to select the UNIX API standard  
the program is intended to comply with.  You might be able to work  
around it with something like:

   .../configure CC='gcc -munix=95'

However, from the description in the GCC manual, it sounds like it's  
actually not a great idea, at least if you plan on linking random  
applications against the Kerberos code; it may cause things to  
misbehave if you link random applications against the Kerberos code.   
Better would be to figure out why gcc doesn't just work.

The HP-UX docs indicate that unix98.o should be in /usr/lib/hpux32  
or /usr/lib/hpux64, depending on the word size you're compiling for.   
If the file is there, it's possible that gcc is just not looking in  
the correct directory for some reason.  If the file isn't there, it  
may be that some HP-UX development package hasn't been properly  
installed on your system.


      Get the freedom to save as many mails as you wish. To know how, go to

More information about the krbdev mailing list