Ken Hornstein kenh at
Thu Dec 30 12:51:08 EST 2004

>krb5_error_code KRB5_LIB_FUNCTION
>krb5_cc_new_unique(krb5_context context, const char *type, 
>		   const char *hint, krb5_ccache *id)

This seems like a great idea, since I've never figured out how
krb5_cc_gen_new() can be useful.

>Jeffrey Altman though the name of the function should be name,
>krb5_cc_unique_id, I don't agree, but isn't married to my name, any better?

I personally think that having "new" in the name makes more sense; I wouldn't
know what "unique_id" would mean just by looking at the function.

>So the user could call this function something like this:
>krb5_cc_new_unique(context, "API", "lha at SU.SE", &id);
>krb5_cc_get_name(context, id) would then maybe return something like this
>"API:console1!lha at SU.SE" or "API:foobar", the hint is just a hint.

This may be a difference between Heimdal and MIT right now, but MIT
returns just the "id" for cc_get_name() (everything after the :).  At least,
that's what FILE and MSLSA do by my reading.  A function that returned the
whole thing would be a good idea, actually.


More information about the krbdev mailing list