kerberos error setup on mac

Emma Lee emma at
Thu Apr 13 01:42:14 EDT 2017

1.2.6 is from 2002.

The current documentation [1] can be found from the website.

If there is no need to build from source, you will probably be happier
using macports [2] or homebrew [3], which are community-run package
managers for macOS/OS X.

For homebrew, because Heimdal Kerberos comes with the OS, MIT Kerberos
is considered a "dupe" according to it's policies. You must tap
homebrew/dupes in order to install krb5, and then force "linking" the
package to use it (that is, your PATH will have /usr/local/bin and
therefore the linked krb5 supercede where system Heimdal Kerberos is).

    $ # install homebrew following the instructions on their website
    $ brew tap homebrew/dupes
    $ brew install krb5
    $ brew link krb5 --force

I have little experience using macports, so will let someone else
throw in their 2c about it.


[1] -
[2] -
[3] -

On Thu, Apr 13, 2017 at 1:04 AM, Ronald Gmail
<ronald.duenas.rodriguez at> wrote:
> Thanks! This is the reference from the mit I followed:
> Regards!
>> On 13 Apr 2017, at 12:14 PM, Benjamin Kaduk <kaduk at> wrote:
>> You should send a link to the procedure you are trying to follow;
>> otherwise we cannot help you.  That is, you say "from the website",
>> but which website?
>> -Ben
>>> On Thu, Apr 13, 2017 at 10:41:28AM +0800, Ronald Gmail wrote:
>>> Hello,
>>> Thanks for your prompt response, however i'm still facing error when compiling the package on mac Sierra OS.
>>> I had followed the procedure which is quite old one.
>>> Looks like nautils does not exist on the latest mac version, I did searched and tried dcsl to modified the services, I'm not sure whether there is sign that dscl is working or not.
>>> Have tried these steps :
>>> 1. From the website I replaced nautil to dscl.
>>> 2. Rebooted my mac.
>>> 3. In the src directory, I excuted configure.
>>> 4. From the resolve path I did executed ./resolve command.
>>> Can you help me to direct to the latest link if you have it?
>>> Thank you,
>>>> On 13 Apr 2017, at 8:02 AM, Benjamin Kaduk <kaduk at> wrote:
>>>> Hi Ronald,
>>>>> On Thu, Apr 13, 2017 at 12:47:36AM +0800, ronald rodriguez wrote:
>>>>> Hi MIT team,
>>>>> Just need help to install on mac, seems the instruction provided is not working on latest mac version, are you able to provide the update steps to install the kerberos master on mac osx?
>>>> This question is better directed at the public kerberos at
>>>> list, and anyway would require more details to be answerable.  (You
>>>> write as if there is only one instruction set globally, which is
>>>> decidedly not true.  You'd need to provide more details about what
>>>> procedure you are following and how it fails in order for anyone to
>>>> help you.)
>>>> -Ben
> ________________________________________________
> Kerberos mailing list           Kerberos at

More information about the Kerberos mailing list