problem trying to configure krb5-1.2.8 with compiler option for 64bit support

Ken Raeburn raeburn at MIT.EDU
Wed Aug 13 15:17:01 EDT 2003

"Swift, Louise" <louise.swift at> writes:

>  I will have to go back and try and resolve using gcc - I'm stuck at
> the moment with the configure working, but the make failing as it
> looks like the linking is trying to use some 32bit module somewhere
> (see STEP 4) - any hints on how to progress getting the make to work?
> If not , when I get back to progressing gcc, I will scan the web then
> post another question about gcc and make, here and on gcc

I suspect our generation of the shared library is pulling in support
files that are built for 32-bit support only.  Or, perhaps, there's an
option (probably -m64) that should be getting passed in to the link
step that isn't, or it gets ignored when building a shared library.

I should give a 64-bit gcc build on Solaris another shot sometime....

> At this point I had to resort to using the SUN compiler.
> Step 5.  install Kerberso MIT on Solaris 8 using 64bit support using
> Sun compiler
> ./configure --with-cc="cc -xarch=v9 -D_XOPEN_SOURCE=500
> -D__EXTENSIONS__" --without-krb4 --enable-shared
> configure and make worked fine, although if you out in the
> --with-tcl=/usr/local you will still get a failure.

If you put a 64-bit Tcl library into /usr/local/lib/v9, that might


More information about the Kerberos mailing list