Problem compiling pam_krb5 on Solaris 8

Parag Godkar paragg at
Mon Nov 18 01:15:45 EST 2002


I have installed MIT Kerberos krb5-1.2.6
on Solaris 8 running on Sun Fire 280R server
with dual UltraSparc III 900 MHz CPUs with
a little help from Mr. Sam Hartman from this
mailing list.

krb5-1.2.6 has been installed in /usr/kerberos

Now I am trying to compile pam_krb5 obtained
via CVS from

I run the following configure command -

./configure --with-krb5=/usr/kerberos  

and I got no errors.

But, when I run make, I get the following
errors -

gcc -c -I/usr/kerberos/include -fpic -g -O2 pam_krb5_auth.c
gcc -c -I/usr/kerberos/include -fpic -g -O2 pam_krb5_pass.c
gcc -c -I/usr/kerberos/include -fpic -g -O2 pam_krb5_acct.c
gcc -c -I/usr/kerberos/include -fpic -g -O2 pam_krb5_sess.c
gcc -c -I/usr/kerberos/include -fpic -g -O2 support.c
gcc -shared -o -Wl,-rpath -Wl,/usr/kerberos/lib -Wl,-rpath -Wl,/usr/kerberos/lib pam_krb5_auth.o pam_krb5_pass.o pam_krb5_acct.o pam_krb5_sess.o support.o -L/usr/kerberos/lib -lkrb5 -lk5crypto -lcom_err -lpam -lsocket -lnsl 
ld: fatal: file /usr/kerberos/lib: unknown file type
ld: fatal: File processing errors. No output written to
collect2: ld returned 1 exit status
make: *** [] Error 1

Can someone guide please.

Parag Godkar

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Kerberos mailing list