krb5 commit: Fix misleading indentation in clnt_udp.c
Greg Hudson
ghudson at mit.edu
Wed Sep 19 12:55:01 EDT 2018
https://github.com/krb5/krb5/commit/20b2a9980e6f2d62875502dfb5c3cb64e17df41b
commit 20b2a9980e6f2d62875502dfb5c3cb64e17df41b
Author: Robbie Harwood <rharwood at redhat.com>
Date: Tue Sep 18 14:19:55 2018 -0400
Fix misleading indentation in clnt_udp.c
gcc warns that the `if` statement doesn't guard the length
assignment, which is true. However, it wouldn't make sense for the
length assignment to be guarded by the `if` clause anyway, since the
previous statement is a `goto`. De-indent for clarity.
src/lib/rpc/clnt_udp.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/src/lib/rpc/clnt_udp.c b/src/lib/rpc/clnt_udp.c
index 3d7a459..49b09e0 100644
--- a/src/lib/rpc/clnt_udp.c
+++ b/src/lib/rpc/clnt_udp.c
@@ -196,7 +196,7 @@ clntudp_bufcreate(
}
if (connect(*sockp, (struct sockaddr *)raddr, sizeof(*raddr)) < 0)
goto fooy;
- cu->cu_llen = sizeof(cu->cu_laddr);
+ cu->cu_llen = sizeof(cu->cu_laddr);
if (getsockname(*sockp, (struct sockaddr *)&cu->cu_laddr, &cu->cu_llen) < 0)
goto fooy;
More information about the cvs-krb5
mailing list