krb5 commit: Modernize cc_file.c and cc_keyring.c

Greg Hudson ghudson at MIT.EDU
Sat May 17 19:54:29 EDT 2014


https://github.com/krb5/krb5/commit/d3dd3d147aa403135d07bfca685aced769e361c2
commit d3dd3d147aa403135d07bfca685aced769e361c2
Author: Greg Hudson <ghudson at mit.edu>
Date:   Sun May 4 11:57:16 2014 -0400

    Modernize cc_file.c and cc_keyring.c
    
    Rename functions not to use the krb5_ prefix, and to use the fcc_ or
    krcc_ prefixes only for ccache method implementations.  Use shorter
    function comments and add missing comments in some cases.  Remove
    forward declarations where they aren't needed.  Use native types
    (uint16_t, void *, etc.) in preference to Kerberos type wrappers.  Use
    "ret" as the variable name for krb5_error_code return values.  Use 0
    instead of KRB5_OK.  Make whitespace conform to current practice.
    Remove old #if 0 blocks.  Don't cast to and from void * or between
    integer types when C guarantees an implicit cast.  Use literal 2 and 4
    for the size of fixed-width 16-bit and 32-bit types.
    
    In cc_file.c, rewrite the header comment to specify the header format
    as updated by version 4 and refer to ccmarshal.c for the principal and
    credential format.  Also add a helper function to return the cache
    version as an integer from 1 to 4, allowing more concise version
    checks.

 src/lib/krb5/ccache/cc_file.c    | 2043 +++++++++++++++-----------------------
 src/lib/krb5/ccache/cc_keyring.c | 1970 ++++++++++++++++---------------------
 2 files changed, 1665 insertions(+), 2348 deletions(-)

Diff larger than 5000 lines; suppressing.


More information about the cvs-krb5 mailing list