Subject: [Class of 2014] Sweatpants tomorrow W20

From: Oliver R Song <[email-masked]>
Date: Wed, 21 Sep 2011 19:53:29 -0400

Sweatpants sales in the Student Center from 2-5!

Come try one on for size.

As a reminder, they're $9 and you can pay with Techcash or Cash. You can only purchase one.

Cheers,
Your 2014 Class Council

---

From: Oliver R Song <[email-masked]>
Date: Wed, 21 Sep 2011 21:18:56 -0400

Correction: Lobby 10 (not the Student center)

Sorry about that!

On Sep 21, 2011, at 7:53 PM, Oliver R Song wrote:

Cheers,
Your 2014 Class Council