Subject: [Class of 2014] Ring Premiere

From: Ishaan Kumar <[email-masked]>
Date: Fri, 27 Jan 2012 00:07:20 +0000

Hey Class of 2014,

We hope you all had great winter breaks and are enjoying IAP.

With the new semester fast approaching we wanted to give you a little something to look forward to, after a year and a half of staring at upperclassmen's rings with envy, it's finally our time!

Join us on Friday, February 10th at 8PM in Kresge Auditorium as we unveil the design of our class's Brass Rat at the 2014 Ring Premiere.

Be sure to follow the countdown at http://www.itscoming.mit.edu and be on the lookout for emails from us as we start to reveal more details about Premiere and our Brass Rat.

- Your Class of 2014 Ring Committee

---

From: Ishaan Kumar <[email-masked]>
Date: Fri, 27 Jan 2012 00:58:48 +0000

The real countdown can be found here: http://itscoming.mit.edu (just remove the `www`prefix).

________________________________________
From: [email-masked] [[email-masked]] on behalf of Ishaan Kumar [[email-masked]]
Sent: January 26, 2012 7:07 PM
To: [email-masked]
Subject: [Class of 2014] Ring Premiere

Hey Class of 2014,