[krbdev.mit.edu #7984] git commit

Greg Hudson via RT rt-comment at krbdev.mit.edu
Fri Aug 8 13:06:52 EDT 2014


Make ksu respect the default_ccache_name setting

Move the logic for resolving and initializing a cache that we're
copying creds into out of krb5_ccache_copy(), and let the caller deal
with it.  Add a helper functions to select/resolve an output ccache in
the default location for the target user after we've switched to the
target user's privileges.  If the destination is a collection, take
care not to change which subsidiary is its primary, and reuse a
subsidiary cache if we can.  If the destination is not a collection,
append a unique value to its name to make a new ccache.

[ghudson at mit.edu: some changes to variable names and comments; move
responsibility for getting target ccache name from
resolve_target_ccache to main]

https://github.com/krb5/krb5/commit/3a456898af626dcab4e1ab0749ca2ccb9ad6162b
Author: Nalin Dahyabhai <nalin at dahyabhai.net>
Committer: Greg Hudson <ghudson at mit.edu>
Commit: 3a456898af626dcab4e1ab0749ca2ccb9ad6162b
Branch: master
 src/clients/ksu/ccache.c |   35 ++-------
 src/clients/ksu/ksu.h    |    6 +-
 src/clients/ksu/main.c   |  181 +++++++++++++++++++++++++++++++++++++---------
 3 files changed, 157 insertions(+), 65 deletions(-)



More information about the krb5-bugs mailing list